Carnet Wiki

Config Alwaysdata

Version 6 — 5 months ago JLuc

À partir de SPIP 4

Le MYSQL de Alwaysdata utilise mariadb 10.6 qui souffre d’un bug qui n’est pas encore contourné par SPIP et donc une fois les fichiers installés on ne peut pas initialiser les tables de la base de donnée (ticket SPIP #4342).

Pour l’instant il faut donc patcher le source : dans le fichier ecrire/req/mysql.php, virer la ligne 702 qui contient . " ENGINE=MyISAM". ainsi que proposé dans ce patch.

À partir de SPIP 4.1

Avec SPIP 4.1, PHP doit disposer de la librairie sodium. C’est le cas par défaut à partir de PHP 7.2 (voir la doc PHP et l’annonce de cette prise en compte)... sauf si l’hébergeur installe un PHP spécialement construit pour ne pas disposer de cette librairie. C’est malheureusement le cas de Alwaysdata, qui, heureusement, fournit un moyen très simple de débrider le PHP proposé en activant les librairies désirées.

La doc générale sur la gestion des extensions est là : https://help.alwaysdata.com/fr/langages/php/installer-une-extension

En bref, pour installer SPIP 4.1, il faut ajouter la ligne suivante dans le php.ini :
extension=sodium.so.
C’est possible de l’y ajouter :
-  lors de la création du site pendant l’étape de configuration
-  à tout moment ensuite, depuis la page “environnement” dans l’admin Alwaysdata.

Il est également possible d’activer le cache APCU de la même manière, ce qui est assez rare pour un hébergement mutualisé. Il faut pour cela ajouter au php.ini la ligne suivante :
extension=apcu.so
Lorsque APCU est activé, on peut alors bénéficier des plugins memoization, xray et cachelab.