Carnet Wiki

Config Alwaysdata

Version 3 — 5 months ago JLuc

Avec SPIP 4.1, PHP doit disposer de la librairie sodium. C’est le cas par défaut... sauf si l’hébergement installe intentionnellement un PHP spécialement construit pour ne pas disposer pas de cette librairie. C’est le cas de Alwaysdata, qui, heureusement, fournit un moyen de débrider le PHP et de lui restaurer les librairies désactivées.

La doc générale sur la gestion des extensions est là : https://help.alwaysdata.com/fr/langages/php/installer-une-extension/

- La doc générale sur les extensions est là : https://help.com/fr/langages/php/installer-une-extension /
- En bref, pour installer SPIP 4.1, il suffit d’ajouter la ligne suivante dans le php.ini :

extension=sodium.so</code>,  >  et c'est possible directement [depuis la page "environnement" dans l'admin Alwaysdata->https://admin.alwaysdata.alwaysdata.com/environment/].


Il est également possible d'installer apcu de la même manière  -- en ajoutant la ligne <code>extension=apcu.so

 —, ce qui est assez rare pour un hébergement mutualisé. Et on peut alors bénéficier des plugins memoization, xray et cachelab.