Multilang - comments Multilang 2019-12-27T07:05:53Z https://files.spip.org/Multilang#comment503510 2019-12-27T07:05:53Z <p>Bonjour,<br class="autobr" /> J'ai installé et paramétré le plugin pour les articles.<br class="autobr" /> Il ne fonctionne pas (SPIP 3.2.7 et PHP 7.2).<br class="autobr" /> Avez-vous une piste ? <br class="autobr" /> Est-il incompatible avec d'autres plugins ?<br class="autobr" /> Merci</p> Multilang 2019-12-17T14:50:33Z https://files.spip.org/Multilang#comment503427 2019-12-17T14:50:33Z <p>Ah ok, oui dans ce cas, je comprends le besoin d'avoir les 2 plugins en même temps. Je sais pas si c'est une bonne pratique ou pas, mais je comprends :)</p> <p>Par contre je ne vois pas de solution simple au niveau interface pour ce cas de figure : il faut bien afficher 2 menus de langues différents, et il n'y a pas de raison d'en rendre un des 2 “moins visible” que l'autre. En tout cas pour multilang, ça pénaliserait les utilisateurs qui ne l'utilisent pas en conjenction avec l'autre plugin, ce qui je pense est la majorité des cas (mais j'ai pas de stats sous la main).</p> Multilang 2019-12-17T13:43:36Z https://files.spip.org/Multilang#comment503422 2019-12-17T13:43:36Z <p>Besoin je ne sais pas ^^<br class="autobr" /> Mais perso il m'arrive souvent de faire des sites multi avec les rubriques commune à toutes les langues, (donc utilisant multi) et des articles traduit.</p> <p>Peut etre est ce une mauvaise pratique ?</p> Multilang 2019-12-02T13:47:35Z https://files.spip.org/Multilang#comment503208 2019-12-02T13:47:35Z <p>Très bien, j'attends donc la 1.4.4 avec impatience ;)</p> Multilang 2019-11-29T16:14:40Z https://files.spip.org/Multilang#comment503192 2019-11-29T16:14:40Z <p>C'est corrigé dans la 1.4.4 qui sera publiée bientôt (mais pas aujourd'hui : on n'a pas de serveur :p)</p> Multilang 2019-11-29T15:18:26Z https://files.spip.org/Multilang#comment503190 2019-11-29T15:18:26Z <p>Bonjour,<br class="autobr" /> Merci pour le retour, je confirme, ce sera corrigé dès que possible.</p> Multilang 2019-11-29T13:22:41Z https://files.spip.org/Multilang#comment503188 2019-11-29T13:22:41Z <p>Bonjour,<br class="autobr" /> Merci à vous pour cette contrib géniale que j'utilise massivement sur mes sites !</p> <p>Depuis une mise à jour récente, multilang ne fonctionne plus dans les crayons (dans l'interface publique). La console de mon navigateur est pleine d'erreur JS.</p> <p>Merci d'y jetter un oeil à l'occasion!</p> <p>Jul</p> Multilang 2019-11-26T12:34:14Z https://files.spip.org/Multilang#comment503169 2019-11-26T12:34:14Z <p>Pour le point 2), il y a un cache d'1 semaine sur le javascript qui gère le menu de langue, il faut sans doute vider le cache pour voir un changement de config tout de suite.</p> <p>Pour le point 1), je plaide coupable votre honneur !<br class="autobr" /> Suite à des retours utilisateurs qui avaient des soucis avec l'ancien menu (pas assez visible et libellés peu clairs), j'ai mis une petite couche de peinture.<br class="autobr" /> Efectivement, le menu est assez ressemblant avec celui de traduction par objets.<br class="autobr" /> Cela dit, dans quel cas de figure y a-t-il besoin d'avoir <i>à la fois</i> les balises <code><multi></code><i>et</i> les “vraies” traductions sur un même objet ?</p> Multilang 2019-11-23T17:22:51Z https://files.spip.org/Multilang#comment503143 2019-11-23T17:22:51Z <p>Le problème s'est réglé, peut-être parce que, dans la configuration du plugin j'ai sélectionné les deux langues :</p> Multilang 2019-11-21T16:01:15Z https://files.spip.org/Multilang#comment503130 2019-11-21T16:01:15Z <p>Et dans la suite, je n'arrive pas à activer le plugin sur les mots clés ou groupe de mot clés. Malgré la case coché dans la configuration.</p> <p>Au ca sou liste des plugins activé sur mon site:<br class="autobr" /> Analyclick 0.3.4 - test<br class="autobr" /> Authority 0.12.0 - stable<br class="autobr" /> Automatic backup 1.2.6 - stable<br class="autobr" /> Control API 1.9.5 - stable<br class="autobr" /> CVT Upload 1.18.0 - test<br class="autobr" /> Déclarer le parent 1.3.5 - dev<br class="autobr" /> Duplicator 2.0.6 - stable<br class="autobr" /> Entries for forms 3.30.0 - stable<br class="autobr" /> Extra fields 3.12.4 - stable<br class="autobr" /> Extra fields (Interface) 3.5.8 - stable<br class="autobr" /> Formidable 3.46.7 - stable<br class="autobr" /> Home article 1.2.2 - stable<br class="autobr" /> Interface de traduction pour objets 1.1.5 - test<br class="autobr" /> LESS CSS 1.4.4 - stable<br class="autobr" /> MailCrypt 2 2.4.5 - stable<br class="autobr" /> minibando 1.3.10 - stable<br class="autobr" /> Multilang 1.4.3 - stable<br class="autobr" /> NoSPAM 2.1.3 - test<br class="autobr" /> Pencils 1.26.19 - stable<br class="autobr" /> Postman 3.7.2 - stable<br class="autobr" /> Raccourci Accordéon 1.0.5 - test<br class="autobr" /> Rang 1.0.13 - test<br class="autobr" /> Recycle bin 3.1.2 - stable<br class="autobr" /> Rubriqueur 2.1.1 - stable<br class="autobr" /> SPIP Bonux 3.5.4 - stable<br class="autobr" /> YAML 2.0.11 - test</p> Multilang 2019-11-21T15:18:08Z https://files.spip.org/Multilang#comment503128 2019-11-21T15:18:08Z <p>Bonjour, je viens de mettre à jour mon site SPIP et par conséquent les plugins<br class="autobr" /> J'utilise “Multilang” & “Interface de traduction pour objets”<br class="autobr" /> Seulement, le changement d'interface rend, l'emploie des deux plugins en parallèlle vraiment perturbant, car beaucoup trop similaire on ne comprend plus rien. (voir screenshoot joint, la zone A correspond à interface de traduction pour objects, la zone B à multilang)</p> <p>C'était bien mieux avec le petit menu discret d'avant.</p> <p>Mais au delà de ce souci esthétique, mon plus gros problème, viens du fait que j'aimerai désactiver “Multilang” pour les articles et ne les garder que pour les rubriques, mais sans succès. Lorsque je décoche article dans configuration du plugin, je n'ai aucun changement.</p> <p>Avez vous constatez cela aussi ?<br class="autobr" /> Merci d'avance.</p> Multilang 2019-11-17T08:18:04Z https://files.spip.org/Multilang#comment503090 2019-11-17T08:18:04Z <p>Souci qui vient d'apparaître, qui empêche l'usage de ce plugin (parfait, par ailleurs, que j'utilise depuis des années), qui ne vient peut-être pas du plugin lui-même.<br class="autobr" /> Voici le problème bloquant : lorsqu'il crée la chaîne : <br class="autobr" /> <code><multi>[fr]texte_fr[en]texte_en</multi></code><br class="autobr" /> Eh bien, maintenant, au lieu de [en] il met [nglis]. Bizarre...<br class="autobr" /> Du coup, ça ne marche plus !<br class="autobr" /> PS : c'est apparu chez moi après la mise à jour du 15/11/2019. Mais maintenant, même si je remet une version précédente du plugin, le problème reste le même.</p> Multilang 2019-07-10T16:30:27Z https://files.spip.org/Multilang#comment501710 2019-07-10T16:30:27Z <p>Hello, c'est très certainement car la balise Credits n'est pas traitée de la même manière.</p> <p>Peux tu essayer quelquechose du genre dans un fichier mes_options.php :</p> <p><code>$GLOBALS['table_des_traitements']['CREDITS']['documents'] = 'extraire_multi(%s, "TYPO", $connect, $Pile[0])';</code></p> Multilang 2019-07-10T15:55:43Z https://files.spip.org/Multilang#comment501709 2019-07-10T15:55:43Z <p>Je précise que dans l'interface privée, multilang semble bien fonctionner : j'ai bien le “no multi” quand la traduction n'est pas faite, et les “multi fr” et “multi en” quand je demande une langue.</p> <p>C'est uniquement dans le rendu (à la fois dans l'interface privée et publique)</p> Multilang 2019-07-10T15:50:46Z https://files.spip.org/Multilang#comment501708 2019-07-10T15:50:46Z <p>Bonjour</p> <p>La traduction semble ne pas fonctionner pour les crédits des images. <br class="autobr" /> Les documents sont bien cochés dans la config du plugin.<br class="autobr" /> Le titre et la description sont bien traduits.<br class="autobr" /> Mais les crédits sont laissés tels quels :</p> <div class="precode"><pre dir="ltr" style="text-align: left;" class="spip"><code><span class="re31"><multi>[fr]Crédits : Observatoire d'Arecibo[en]Credits : Arecibo Observatory</multi></span></code></pre></div> <p>et cela m'affiche <var>[fr]Crédits : Observatoire d'Arecibo[en]Credits : Arecibo Observatory</var> sous mon image</p> Multilang 2017-10-11T18:14:45Z https://files.spip.org/Multilang#comment493711 2017-10-11T18:14:45Z <p>Super merci marcimat, je m'étais gardé cela pour le week end ;)</p> Multilang 2017-10-11T14:55:19Z https://files.spip.org/Multilang#comment493710 2017-10-11T14:55:19Z <p>Merci beaucoup! :)</p> Multilang 2017-10-11T14:33:23Z https://files.spip.org/Multilang#comment493709 2017-10-11T14:33:23Z <p>Bonjour Julien,<br class="autobr" /> Tu avais raison. J'ai corrigé ça en même temps que le passage en 3.2.</p> <p>MM.</p> Multilang 2017-10-10T09:29:40Z https://files.spip.org/Multilang#comment493682 2017-10-10T09:29:40Z <p>Bonjour,<br class="autobr" /> le plugin Multilang ne fonctionne pas sur “groupe de mots clés” il me semble. Je n'ai pas les raccourcis typographique pour changer de langue.</p> Multilang 2016-08-30T22:23:46Z https://files.spip.org/Multilang#comment488763 2016-08-30T22:23:46Z <p>Ces classes ont été ajoutées par la révision 98267 de la zone <a href="http://zone.spip.org/trac/spip-zone/changeset/98267/" class="spip_url spip_out auto" rel="nofollow external">http://zone.spip.org/trac/spip-zone/changeset/98267/</a></p> Multilang 2016-08-30T22:16:39Z https://files.spip.org/Multilang#comment488762 2016-08-30T22:16:39Z <p>Du coup il faudrait brancher un système d'autorisation dessus. Mettre peut être une autorisation simpliste au minimum qui retourne true tout le temps et que tu surchargerais dans un fichier d'options</p> <p>Tu peux essayer cela et l'envoyer sur la zone si ça fonctionne</p> Multilang 2016-08-08T08:31:42Z https://files.spip.org/Multilang#comment488488 2016-08-08T08:31:42Z <p>Avec ce plugin, pourrait-on avoir la possibilité de restreindre l'affichage des langues à certains utilisateurs ? Dans l'espace privé uniquement.</p> <p>Ou c'est un autre plugin qu'il faudrait faire?</p> <p>Julien.</p> Multilang 2016-04-22T12:04:28Z https://files.spip.org/Multilang#comment487086 2016-04-22T12:04:28Z <p>Petit souci de mise en page, il manque la classe “editer” sur le li du champ numéro (pour les champs numérotables), il faut rajouter la classe “editer” lignes 375, 378 et 381 du fichier javascript/multilang.js</p> <p>ex ligne 375 :<br class="autobr" /> <code>.before('<li class="editer editer_'+numid+'"><label for="titre_numero">'+multilang_lang.numero+'</label><input id="'+numid+'" name="titre_numero" type="text" value="'+el.field_pre_lang+'" size="4" class="text nomulti" /></li>');</code></p> Multilang 2015-09-20T17:05:34Z https://files.spip.org/Multilang#comment483758 2015-09-20T17:05:34Z <p>Bonjour j'ai un souci avec le plugin. lorsque j'ai une entrée dont la traduction est la même dans plusieurs langues par exemple, la balise multi que l'on vois lorsqu'on clique sur tout, se contente de la version dans la langue d'origine. Ce qui dans l'absolu ne me gène pas.</p> <p>En revanche sur le site public il ajoute dans le cas là avant mon titre un <span lang="fr"> qui me retourne uen erreur W3C.</span></p> <p>Sauriez vous comment résoudre ce comportement pour éviter que ne s'ajoute ce span inutile ? Merci.</p> Multilang 2015-01-14T10:15:00Z https://files.spip.org/Multilang#comment478843 2015-01-14T10:15:00Z <p>Ok normalement c'est modifié</p> <p>Merci du retour</p> Multilang 2015-01-13T08:19:34Z https://files.spip.org/Multilang#comment478816 2015-01-13T08:19:34Z <p>Problème rencontré le 13 janvier 2015 dans ce qui semble être la dernière mise à jour de la version 1.1.0 du plugin.</p> <p>Il manqua apparemment le " de fermeture - à la ligne 30 - du fichier paquet.xml:</p> <div class="precode"><pre dir="ltr" style="text-align: left;" class="xml"><code><span class="sc3"><span class="re1"><utilise</span> <span class="re0">nom</span>=<span class="st0">"crayons"</span> <span class="re0">compatibilite</span>=<span class="st0">"[1.13.0;] ></utilise></span></span></code></pre></div> <p>à la place de:</p> <div class="precode"><pre dir="ltr" style="text-align: left;" class="xml"><code><span class="sc3"><span class="re1"><utilise</span> <span class="re0">nom</span>=<span class="st0">"crayons"</span> <span class="re0">compatibilite</span>=<span class="st0">"[1.13.0;]"</span> <span class="re2">></span><span class="re1"></utilise<span class="re2">></span></span></span></code></pre></div> <p>Ce qui pose un problème lors de l'installation du plugin.</p> <p>Merci pour ce plugin très utile.</p> Multilang 2013-10-01T11:21:20Z https://files.spip.org/Multilang#comment471209 2013-10-01T11:21:20Z <p>Bonjour,<br class="autobr" /> Je voudrais savoir comment mettre les liens cliquables des langues sur la page d'accueil du site?<br class="autobr" /> Quels balises ou code faut il insérer?<br class="autobr" /> Merci</p> Multilang 2013-09-02T12:06:43Z https://files.spip.org/Multilang#comment470486 2013-09-02T12:06:43Z <p>Ce plugin est formidable et me sauve la vie, vraiment. Parce qu'effectivement ça rend la saisie des mots-clés et des titres des documents tellement plus confortable</p> <p>Cela dit, il y a un truc un peu bizarre, je suis sous SPIP 3 (toute dernière version) et, bien qu' “Article” soit décoché dans les paramètres du plugin, Multilang reste actif dans les articles.</p> <p>Je crois que c'est dû à un autre réglage, mais j'ai oublié lequel.</p> Multilang 2013-05-06T14:50:29Z https://files.spip.org/Multilang#comment467709 2013-05-06T14:50:29Z <p>Bonjour,</p> <p>je ne suis pas si c'est ici que je dois poster cette question ou plutôt dans champs extras ou saisies.</p> <p>Quand je déclare un champ extra de (type textarea dans la table spip_syndic) via l'api de champs extras, le champ reçoit la classe <i>multi_lang_no_multi</i> et le javascript n'agit pas sur ce champ.</p> <p>Selon la documentation le javascript devrait réagir sur textarea, ce qu'il fait pour le textarea “descriptif” du formulaire mais pas le champ extra; ajouter une classe “text” ne change rien non plus.</p> <p>Si par contre j'entre manuellement la structure multi et je sauvegarde, alors il reconnait le champ extra et l'inclue dans la gestion des langue par le plugin.</p> <p>Comment dois-je déclarer ce champ que le javascript l'inclut d'office?</p> <p>Merci</p> <p>Rainer</p> Multilang 2013-01-24T14:44:02Z https://files.spip.org/Multilang#comment464721 2013-01-24T14:44:02Z <p>Bonjour tout le monde,<br class="autobr" /> Je remercie le créateur de ce plugin, qui, une fois installé sur le site, à laisser entendre un grand souffle de soulagement de la part de mes utilisateurs : “Oufffff, plus besoin de saisir ces PUxAINS de balises multi !!! Hourra!”<br class="autobr" /> Par contre, nous utilisions également des éléments hors balises, il est vraiment regrettable que le bouton “tout”, nous contraignent aux champs complets en lecture seule ...<br class="autobr" /> Il serait génial de pouvoir éditer celui-ci, grace a quoi nous pourrions mettre du texte hors balises.</p> <p>De plus mes utilisateurs rencontrent également des soucis, lorsque ils saisissent qu'une seule langue dans l'article (dans l'optique de mettre l'autre langue dans un second temps), et que celle-ci n'est pas celle par défaut. J'essaierais de détailler cela dans un autre post.</p> <p>Merci à vous,</p> <p>Jul</p> Multilang 2012-10-25T10:51:15Z https://files.spip.org/Multilang#comment462570 2012-10-25T10:51:15Z <p>bonjour, non pas trouvé j'ai enlevé sarka et installe soyezcreateur, cela fonctionne bien</p> Multilang 2012-10-25T07:51:35Z https://files.spip.org/Multilang#comment462549 2012-10-25T07:51:35Z <p>Bonjour, et as-tu trouvé la solution ? je cherche aussi. Merci d'avance !</p> Multilang 2012-10-05T14:57:34Z https://files.spip.org/Multilang#comment461912 2012-10-05T14:57:34Z <p><strong>Erratum :</strong> après investigation ce plugin n'est pas en cause il sagirait plutôt dans soucis dans comments.</p> <p>Milles excuses.</p> <p>Alexandre</p> Multilang 2012-10-05T14:34:50Z https://files.spip.org/Multilang#comment461910 2012-10-05T14:34:50Z <p>Bonjour,<br class="autobr" /> Génial ce plugin!</p> <p>Par contre je rencontre un soucis, je m'explique:<br class="autobr" /> Je viens de concevoir un site donc multilangue et ne sachant pas exactement les langues finales j'ai utilisé au départ le francais et l'anglais tous marché nickel.</p> <p>Puis un fois réalisé j'ai du ajouter l'allemand, je l'ajoute dans l'admin je vide le cache puis je vais dans un article déjà rédigé pour ajouter la traduction allemande: j'ai bien dans la barre de langue de et quand je clic dessus tous marche normal, je renseigne la traduction.</p> <p>Et pour finir je sauvegarde l'article, et la <strong>problème </strong> l'édition n'est pas prise en compte.</p> <p>J'ai vérifier la requete ajax c'est belle et bien la bonne chaine qui par :</p> <p>exemple : < multi >[fr]Accueil[en]Home[de]Welcomen</p> <p>Le seul moyen que j'ai trouvé pour modifier la chaine c'est en passant par phpmyadmin (pas très userfriendly).</p> <p>Et quand je veux modifier l'article via l'admin (après avoir ajouter [de]Welcomen via phpmyadmin), tjr aucune modif prise en compte.</p> <p>En esperant avoir été asse clair.</p> <p>D'avance merci,<br class="autobr" /> Alexandre</p> Multilang 2012-09-02T21:11:52Z https://files.spip.org/Multilang#comment460847 2012-09-02T21:11:52Z <p>Oups, je n'avais pas activé les filtres propres sur ces champs extra. <br class="autobr" /> Mea culpa</p> Multilang 2012-09-02T21:06:42Z https://files.spip.org/Multilang#comment460846 2012-09-02T21:06:42Z <p>Bonjour,</p> <p>J'utilise sur un spip3 ce plugin — qui au passage est vraiment vraiment très utile, merci — couplé au plugin champ extra. Et là, je retrouve sur le site public le contenu des deux langues l'un au dessous de l'autre.</p> <p>Est-il possible que ces deux plugins ne soient pas compatibles ? Quelqu'un a déjà eu ce cas de figure ?<br class="autobr" /> Merci !</p> Multilang 2012-04-13T20:00:48Z https://files.spip.org/Multilang#comment456273 2012-04-13T20:00:48Z <p>bonsoir<br class="autobr" /> j'utilise spip 2.1 avec sarka spip, j'ai installé multilang, mais quand je suis sur un article et que je souhaite modifier la langue, j'obtiens une erreur 404. J'ai lu que certaines personnes avaient eu ce problème mais je n'ai pas trouvé la correction à faire, quelqu'un pourrait il m'aider ?<br class="autobr" /> merci</p> Multilang 2012-02-24T08:56:20Z https://files.spip.org/Multilang#comment454799 2012-02-24T08:56:20Z <p>C'est possible en le configurant pour les articles (utiliser cfg pour cela) mais ce n'est pas dans l'install par défaut car SPIP a un système de traduction pour les articles...</p> Multilang (en test) 2011-11-19T11:01:42Z https://files.spip.org/Multilang#comment451999 2011-11-19T11:01:42Z <p>Bonjour,</p> <p>Merci pour ce plugin, découvert à l'occasion de la mise-à-jour de sécurité récente, qui va (sans doute) me permettre de basculer en v2.1 un site toujours bloqué en 1.9 pour MultiLangue !</p> <p>Mais il semble qu'il y ait plusieurs incompatibilités, (en cours de tests sur une V2.1.12 neuve) <br />- d'une part avec la lame “tout en couleurs” du couteau suisse (comme implicitement dit ci-dessus), <br />- d'autre part avec le “bandeau” (les menus n'apparaissent que comme un trait noir <i>“par moments”</i>....</p> <p>@ suivre<br class="autobr" /> Yannx</p> Multilang (en test) 2011-10-14T14:39:34Z https://files.spip.org/Multilang#comment450850 2011-10-14T14:39:34Z <p>Le rêve serait que cela fontionne de la même façon pour les articles :-)<br class="autobr" /> En tout cas c'est beaucoup plus intuitif pour les rédacteurs.</p> Multilang (en test) 2011-10-14T14:28:23Z https://files.spip.org/Multilang#comment450848 2011-10-14T14:28:23Z <p>Excellent plugin, devrait être intégré dans le core de spip 3.<br class="autobr" /> JE viens de le découvrir et il vas me simplifier la vie.. Expliquer à mes client le coup de la balise multi était toujours délicat :D !!!</p> <p>Merci aux dev !</p> Multilang (en test) 2011-07-13T08:56:43Z https://files.spip.org/Multilang#comment447709 2011-07-13T08:56:43Z <p>Bonjour</p> <p>1) C'est le fonctionnement normal. Comme indiqué dans l'article, “tout” permet de visualiser le contenu d'un champ... (je viens de rajouter qu'il ne permet pas la modification)</p> <p>2) Rajouté dans la liste des choses à faire</p> <p>Merci pour le retour</p> Multilang (en test) 2011-07-12T23:06:29Z https://files.spip.org/Multilang#comment447703 2011-07-12T23:06:29Z <p>Bonjour et merci pour ce plugin,</p> <p>Je l'utilise avec une version 2.1.10 [17657] de SPIP pour un site bilingue (fr-en) et (notamment) le plugin <strong>couteau suisse</strong>, et je voulais rapporter 2 bugs:</p> <p>1) lorsque je clique sur tout, les champs s'affichent avec les raccourcis spip <code><multi></code> mais impossible <strong>d'éditer </strong> quoi que ce soit. Pour pouvoir modifier le texte, je dois cliquer soit sur <code>[fr]</code> soit sur <code>[en]</code> pour que le texte soit éditable.</p> <p>2) le plugin semble incompatible avec l'option “<strong>Tout en couleurs</strong>” du couteau suisse: lorsque j'essaye de colorer du texte ex: <code>découvrir [gold] {{Paris}}[/gold]</code>, le texte s'affiche correctement en public mais dans la partie privée le code n'est pas bien interprété et s'affiche <code>découvrir {{</code> et plus rien ensuite...</p> <p>Savez vous comment faire disparaître ces petits bugs?</p> <p>Merci encore pour ce plugin, vivement qu'il soit complètement opérationnel !</p> Multilang (en test) 2011-05-30T17:54:53Z https://files.spip.org/Multilang#comment446236 2011-05-30T17:54:53Z <p>Hello</p> <p>As tu essayé avec le filtre supprimer_tags ? (<a href="http://www.spip.net/fr_article4315.html" class="spip_url spip_out auto" rel="nofollow external">http://www.spip.net/fr_article4315.html</a>)</p> Multilang (en test) 2011-05-30T15:49:08Z https://files.spip.org/Multilang#comment446228 2011-05-30T15:49:08Z <p>Merci pour cette contribution fort utile, toutefois je dois l'abandonner à moins qu'il y aie une solution. Dans le cadre d'un projet je dois générer un fichier xml basé sur les mots clés du site (des pays). J'utilise donc le multilinguisme sur les mots clés. Toufefois le xml accepte uniquement le titre du mot clé mais n'accepte pas le mot sil est entouré d'un span=“fr”... j'ai donc inséré la balise TITRE ainsi : <abbr title="typo)">(#TITRE</abbr> et là le problème est à moitié résolu. Les span disparaissent sauf dans le cas suivant (ce qui m'empêche de générer un xml qui fonctionne) :</p> <p>lorsque je crèe le mot Afghanistan, sa traduction en anglais est la même, donc le système ne crèe pas un multi avec français et anglais mais uniquement avec le français :( et donc dans le code span apparait.</p> <p>La seule façon que jai c'est d insérer manuellement les champs multi et là tout fonctionne...</p> Multilang (en test) 2011-02-17T09:47:57Z https://files.spip.org/Multilang#comment441170 2011-02-17T09:47:57Z <p>Chouette plugin, juste quelques questions/remarques en passant ...</p> <p>- Comment se détermine l'ordre d'affichage des langues [fr][en][nl][Tout] et comment le modifier ? <br />- Dans l'interface privée on ne voit que la visualisation du contenu de la première langue, ce serait bien de mettre aussi l'affichage des langues [fr][en][nl] pour visualiser le contenu des autres langues sans devoir passer par l'édition. <br />- Le suivi des modifications est rendu compliqué ... <br />- Pour les urls propres, on se retrouve avec une url qui prend le titre de la première langue par défaut, je ne sais pas si ce serait possible d'avoir facilement un système qui génèrerait les urls en fonction de la langue: titre-fr/titre-nl/titre-en</p> Multilang (en test) 2011-02-17T09:22:55Z https://files.spip.org/Multilang#comment441169 2011-02-17T09:22:55Z <p>Etrange, j'avais 3 langues de sélectionnée et le plugin n'était pas chargé.</p> <p>En rajoutant une langue, le plugin s'active bien et reste fonctionnel quand on revient à 3 langues.</p> Multilang (en test) 2011-02-17T09:06:36Z https://files.spip.org/Multilang#comment441168 2011-02-17T09:06:36Z <p>Tu as bien défini plusieurs langues ?<br class="autobr" /> Regarde avec firebug, s'il n'y a pas d'erreurs js</p> Multilang (en test) 2011-02-17T08:59:50Z https://files.spip.org/Multilang#comment441167 2011-02-17T08:59:50Z <p>Ce plugin a l'air d'être bien intéressant.</p> <p>Mais une installation en version 2.1.8 ne m'affiche strictement rien dans les articles, les rubriques,... malgré que tout soit coché à oui dans /?exec=cfg&cfg=multilang</p> <p>Une idée de comment vérifier si le plugin est bien actif ?</p> Multilang 2010-11-30T14:00:38Z https://files.spip.org/Multilang#comment437646 2010-11-30T14:00:38Z <p>Superbe, ça marche avec spip 2.1.2, mais je ne pouvais pas bien lire l'image in background dans les textarea - donc, j'ai changé le CSS pour le mettre à 95% , pas de 98%. Mais, autrement, tiptop, merci !</p> Multilang 2010-11-30T12:17:32Z https://files.spip.org/Multilang#comment437640 2010-11-30T12:17:32Z <p>Tu peux essayer. Ca se passe dans le fichier multilang_pipelines.php à l'insertion du script</p> Multilang 2010-11-30T09:13:01Z https://files.spip.org/Multilang#comment437626 2010-11-30T09:13:01Z <p>Le problème c'est que j'ai selectionné une dizaine de langue pour pouvoir gérer la traduction des articles.<br class="autobr" /> mais le multilinguisme du site global n'est que de 4 langues forcées.<br class="autobr" /> Puis-je forcer les langues dans votre plugin également en dur dans le code ?</p> Multilang 2010-11-30T08:34:34Z https://files.spip.org/Multilang#comment437623 2010-11-30T08:34:34Z <p>Bonjour</p> <p>Le plugin n'utilise que les langues qui sont cochées dans la page ecrire/?exec=config_multilang</p> Multilang 2010-11-30T08:20:43Z https://files.spip.org/Multilang#comment437621 2010-11-30T08:20:43Z <p>Bonjour,<br class="autobr" /> j'ai installé votre plugin qui marche très bien.<br class="autobr" /> J'ai une petite difficulté sur mon site car toutes langues sont cochées pour gérer les traductions mais le site global n'utilise que 4 langues.<br class="autobr" /> Est-ce possible de configurer que ces 4 langues dans le multilangue ?<br class="autobr" /> merci d'avance.</p> Multilang 2010-09-16T09:23:05Z https://files.spip.org/Multilang#comment434493 2010-09-16T09:23:05Z <p>Désolé, j'ai trouvé, c'est un problème de multi manquant dans les articles que j'ai testés ..... cà marche impec....</p> Multilang 2010-09-16T09:13:32Z https://files.spip.org/Multilang#comment434492 2010-09-16T09:13:32Z <p>Je précise qu'il voit les langues au niveau “menu” mais lorsque je clique il me fait une erreur 404 sauf pour la page d'accueil.</p> Multilang 2010-09-16T09:08:44Z https://files.spip.org/Multilang#comment434491 2010-09-16T09:08:44Z <p>Bonjour,<br class="autobr" /> J'ai un soucis au niveau du comportement de #MENU_LANG avec les balises multi.<br class="autobr" /> Il ne me trouve pas les traductions.<br class="autobr" /> Quelqu'un chez qui çà fonctionne aurait t'il un bout de code à me montrer ?<br class="autobr" /> Merci</p> Multilang 2010-09-09T11:01:06Z https://files.spip.org/Multilang#comment434197 2010-09-09T11:01:06Z <p>Hello</p> <p>Je viens de revérifier. Pour moi ca fonctionne correctement avec PPP... Faudrait vraiment que je puisse accéder à du code pour essayer de comprendre ce qui ne va pas chez toi</p> Multilang 2010-09-08T07:16:23Z https://files.spip.org/Multilang#comment434120 2010-09-08T07:16:23Z <p>bonjour Yffic,</p> <p>Merci pour ton message.<br class="autobr" /> J'ai fait qq recherches de mon côté et j'ai (re)découvert une chose. Lorsque j'ai désactivé le plugin “porte plume partout”, le menu langue est apparu dans mes mots-clefs !<br class="autobr" /> J'ai déjà écrit un commentaire à ce sujet. Je travaille habituellement avec FF. Malheureusement, je ne sais vraiment pas d'où vient le problème.</p> <p>As-tu besoin d'autres informations ou précisions ?</p> Multilang 2010-09-06T07:34:53Z https://files.spip.org/Multilang#comment434002 2010-09-06T07:34:53Z <p>bizarre, peux tu m'envoyer en privé un code d'accès rédacteur au site en question ?</p> Multilang 2010-09-06T07:06:12Z https://files.spip.org/Multilang#comment433999 2010-09-06T07:06:12Z <p>oui. l interface multilang s'affiche uniquement sur les rubriques, mais pas avec les mots-clefs !</p> Multilang 2010-09-04T20:23:06Z https://files.spip.org/Multilang#comment433962 2010-09-04T20:23:06Z <p>oui super, c'est corrigé,<br class="autobr" /> merci, c'est du tonnerre !</p> Multilang 2010-09-04T13:51:39Z https://files.spip.org/Multilang#comment433955 2010-09-04T13:51:39Z <p>Hello, je viens de retester, pour moi ca fonctionne. Le menu apparait-il dans pour les rubriques par exemple ?</p> Multilang 2010-09-04T13:28:25Z https://files.spip.org/Multilang#comment433954 2010-09-04T13:28:25Z <p>Vu... C'est normalement corrigé</p> Multilang 2010-09-03T14:49:48Z https://files.spip.org/Multilang#comment433937 2010-09-03T14:49:48Z <p>Effectivement, sur 2.1.1, enfin 2.1.2 ;-) , obligé de saisir manuellement la première fois les champs multi. Il me semble que ça n'était pas la cas sur les précédentes versions. Y a-t-il une raison particulière à cette logique qui diminue la force de cet excellent plugin ?</p> Multilang 2010-08-19T14:14:34Z https://files.spip.org/Multilang#comment433435 2010-08-19T14:14:34Z <p>Bonjour,</p> <p>J'ai constaté une chose. Même en paramétrant le plugin avec CFG, le plugin ne me propose aucune interface multilingue pour les mots-clefs ou encore la configuration du site !</p> Multilang 2010-08-19T13:58:09Z https://files.spip.org/Multilang#comment433433 2010-08-19T13:58:09Z <p>Bonjour,<br class="autobr" /> j'utilise le plugin sur un SPIP 2.1.1, j'ai juste 2 questions :<br class="autobr" /> quel est l'avantage de mettre les champs qui n'ont pas encore de balise multi en lecture seule ?</p> <p>il me semble qu'il y a aussi un petit problème : lorsqu'aucune balise multi n'existe encore dans le champ, elles ne sont pas ajoutées automatiquement, elles sont prises en compte seulement si elles existent... l'automatisation serait bien venue pour éviter la rédaction fastidieuse, et les balise multi resteraient inconnue du rédacteur novice... <br class="autobr" /> est-ce un problème technique ?<br class="autobr" /> aurait-il fallu créer les articles après la mise en place du plugin ?</p> <p>merci et bon courage,</p> Multilang 2010-06-30T13:52:50Z https://files.spip.org/Multilang#comment432226 2010-06-30T13:52:50Z <blockquote class="spip"> <p>Les textarea munis de ckeditor (le texte des rubriques notamment), ne se traduisent pas en multi. Spip enregistre le texte de la dernière modification dans ce champs. <br class="autobr" /> J'imagine que ça vient du traitement du texte par ckeditor. Est-ce voulu ?</p> </blockquote> <p>On pourrait parler des plombes sur l'utilisation de Ckeditor ... Je pense plutôt que tu devrais te tourner vers les mainteneurs (s'ils existent) de ce plugin.</p> <p>Il n'y a aucune modif prévu à notre niveau pour le supporter en tout cas.</p> Multilang 2010-06-30T12:57:43Z https://files.spip.org/Multilang#comment432224 2010-06-30T12:57:43Z <p>Bonjour,<br class="autobr" /> Les textarea munis de ckeditor (le texte des rubriques notamment), ne se traduisent pas en multi. Spip enregistre le texte de la dernière modification dans ce champs. <br class="autobr" /> J'imagine que ça vient du traitement du texte par ckeditor. Est-ce voulu ? Ou y a t il des modifications prévues à ce niveau ? <br class="autobr" /> A bientôt, et encore bravo pour ce plugin indispensable pour Spip.</p> Multilang 2010-06-30T07:07:27Z https://files.spip.org/Multilang#comment432201 2010-06-30T07:07:27Z <p>(désolé, je colle mon précédent post en réponse)</p> <p>Merci pour les infos.<br class="autobr" /> Je n'ai pas eu l'occasion de tester sous IE.<br class="autobr" /> Par contre, il y a tjs un problème avec porte plume partout sous FF3.6 et safari 5.0.<br class="autobr" /> J'avais installé ppp pour obtenir une barre typographique sur le champ chapeau de mon formulaire d'article. Lorsque j'ai installé et activé le plugin multilang, la barre typo sur les champs chapeau avait disparu. Si je désactive multilang, alors la barre typo réapparaît comme par magie.</p> <p>Je n'ai pas plus d'indications pour le moment, car je ne sais ce qui est la source du problème. Mais je te réponds volontiers si tu as des questions précises.</p> <p>Merci pour ton travail</p> Multilang 2010-06-29T21:10:23Z https://files.spip.org/Multilang#comment432194 2010-06-29T21:10:23Z <p>Un grand merci pour cette contribution qui me permet de faire évoluer un site bloqué depuis si longtemps en 1.9x par l'utilisation de l'ancien plugin barre multilangues.<br class="autobr" /> Bravo et encore merci !</p> Multilang 2010-06-29T13:16:52Z https://files.spip.org/Multilang#comment432178 2010-06-29T13:16:52Z <p>Bonjour, <br class="autobr" /> Et merci pour ce plugin tant attendu. Le soucis du non-affichage sous IE7 semble réglé, en conservant toutefois le petit décalage de l'input du numero vers le bas. Mais rien de bien grâve, par rapport à ce qu'IE 7 est capable de générer comme Bug.</p> Multilang 2010-06-29T12:55:15Z https://files.spip.org/Multilang#comment432176 2010-06-29T12:55:15Z <p>Re</p> <p>Concernant le problème avec PPP, je n'arrive pas à le reproduire, ni sous FF ni sous IE... Vérifie que la correction précédente n'a pas fait disparaître ce soucis. Sinon, donne moi plus d'infos</p> Multilang 2010-06-29T12:44:59Z https://files.spip.org/Multilang#comment432175 2010-06-29T12:44:59Z <p>Salut</p> <p>J'ai normalement corrigé le problème sous IE... Mais je n'ai testé que sous IE8, pas de IE7 sous la main...</p> Multilang 2010-06-29T07:57:35Z https://files.spip.org/Multilang#comment432151 2010-06-29T07:57:35Z <p>salut à tous,<br class="autobr" /> je pense aussi c'est un réel besoin, bravo pour le développement déjà fait...</p> <p>à l'installation sur SPIP 2.1 tout est ok, je teste encore... avant d'adopter...</p> Multilang 2010-06-29T06:52:15Z https://files.spip.org/Multilang#comment432146 2010-06-29T06:52:15Z <p>Sous IE, les boutons permettant de changer de langue (par ex [fr] [en]) ne s'affiche pas. On ne voit que le titre de la rubrique dans une langue et il est impossible de le visualiser dans une autre langue.</p> Multilang 2010-06-28T12:51:42Z https://files.spip.org/Multilang#comment432129 2010-06-28T12:51:42Z <p>Bonjour,</p> <p>J'ai constaté un souci avec le plugin Multilang. Lorsque les plugins multilang + porte plume partout sont activés ds spip 2.1, la barre d'outils porte plume disparaît dans les champs supplémentaire. Si je déactive multilang, alors les barres d'outils réapparaissent normalement.</p> <p>Autre problème, ce plugin ne semble pas fonctionner normalement ds IE</p> Multilang 2010-06-27T00:19:17Z https://files.spip.org/Multilang#comment432087 2010-06-27T00:19:17Z <p>Merci pour cette contribution. A peine je l'ai lu, je me suis empressé de la tester. En plus, elle arrive à point nommé pour moi. l'adopter c'est l'essayer.<br class="autobr" /> Résultat 10/10.<br class="autobr" /> Il y a un réel besoin d'utiliser un plugin comme celui-ci pour les sites multilingues. ça fait un bout de temps que je l'attends. <br class="autobr" /> Vivement que ça passe en stable.<br class="autobr" /> Merci!</p>