Que faire si le .php3 n'est pas reconnu ? - comments > J'ai releasé une version de SPIP 1.7 en PHP 4 (MS IIs compliant) 2004-03-07T11:34:55Z https://files.spip.org/Que-faire-si-le-php3-n-est-pas#comment7226 2004-03-07T11:34:55Z <p>N'ayant pas Apache comme serveur, ayant rencontré<br class="autobr" /> plusieurs problèmes d'extensions avec les précédentes version de SPIP(fonction 'rechercher' invalide même avec l'extension php3 validée sur le serveur)<br class="autobr" /> j'ai immédiatement pris l'initiative de réaliser la conversion->php4 de la version 1.7.</p> <p>(Mais moi j'ai utilisé Crimson Editor)</p> <p>La version est ok pour un IIs, et reste fonctionnelle sur mon Apache local.<br class="autobr" /> Je l'ai accompagné du biospip dernière version, lui aussi converti en php4.</p> <p>On m'objectera que c'est futile comme release. Je répondrai que l'extension php3 fait super outdaté dans une barre d'adresse.</p> <p>Où est-ce que je pose le lien pour offrir le download ?</p> pitite remarque 2003-09-16T15:25:42Z https://files.spip.org/Que-faire-si-le-php3-n-est-pas#comment3424 2003-09-16T15:25:42Z <p>chez certains hébergeurs il est possible de mettre ces lignes de codes dans un fichier .htaccess à la racine de votre site, si ça ne marche pas voir les autres solutions :-D</p> > Ou alors, pour modifier une version existante ... 2003-09-15T17:44:37Z https://files.spip.org/Que-faire-si-le-php3-n-est-pas#comment3413 2003-09-15T17:44:37Z <p>1°</p> <p>Utiliser ce très bel outil qu'est l'éditeur “UltraEdit” (<a href="http://www.ultraedit.com" class="spip_url spip_out auto" rel="nofollow external">http://www.ultraedit.com</a>) en lui demandant de remplacer tous les «.php3» par des «.php» dans les fichiers d'un dossier (et sous-dossiers) déterminé(s).</p> <p>2°</p> <p>Puis d'utiliser cet autre très bel outil qu'est le gestionnaire de fichier “Total Commander” (<a href="http://www.ghisler.com/accueil.htm" class="spip_url spip_out auto" rel="nofollow external">http://www.ghisler.com/accueil.htm</a>) pour renommer par lot tous les fichiers dont le suffixe est «php3» par «php».</p>