Carnet Wiki

Version 3 — January 2017 erational

Page pour regrouper des informations sur la compatibilité de SPIP et ses composants avec PHP 7

Noyau

Branche Version maintenue Compatible PHP 7 }

|SPIP 1 . 9|||
|SPIP 2.0|||
|SPIP 2.1|x|x|
|SPIP 3.0|x||
|SPIP 3.1|x|x|

Quand l’information est stable, à reporter sur la page officielle
http://www.spip.net/fr_article4351.html

Noyau

|Branche|Version maintenue|Compatible PHP 7}|
|SPIP 1.9|||
|SPIP 2.0|||
|SPIP 2.1|x|x|
|SPIP 3.0|x||
|SPIP 3.1|x|x|

Pour SPIP 2.1, on sortira peut-être 2 branches pour assurer les compatibilités PHP 7- et PHP7+

Plugins

Noter ici les incompatibilités connues ....